Announcement

Collapse
No announcement yet.

SAFC looses memory

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SAFC looses memory

    So i finally bit the bullet and bought anew MAF- that is what was wrong with my engine- water fried the maf, pretty much knew it, but wanted to try to repair it, and all the other questionable wiring first.

    Now the engine runs, but not super smooth. So i started going through the settings on the APEX SAFC 2. I didnt install this item, i dont have any sort of manual for it either. So i didnt know where to set things. Did a little research and got the basics set correctly.


    However, i noticed an issue. When i turn off the car the SAFC seems to loose its memory. It sounds like an issue w/ not having constant power to me off the top of my head. But i looked at the wiring again, and it looks correct. I know all the connections are good b/c i just re-did all of them.
    Every time i startup, I have to re-set the sensor type (hot wire), and the in/out settings (defaults to 1 and 1, needs 5 and 5) although it seems to run either way, but not on any other settings there.

    Of course any fuel adjustments, my high and low throttle %s, and the tuning ranges (1000, 2000, 2500, 3000, etc..) all have to be re-set every time I start up.

    I noticed when i re-did the ECU wiring, i placed the brown and black grounds TOGETHER, i later found that this is a NO NO, and i re-did the wiring there tonight. Still though, after re-doing the ground wiring connections, teh same problem persists.

    Anyone had this happen to them?

    Any ideas of what might cause this?

    Anyone ever try go use another constant power source in the car (like the cig lighter, or dome light or something that has constant power). If so, is there any risk of frying the SAFC if the other constant power circuit has too much amperage going through it?

    Worst case i might just remove the stupid thing- Car has a jim wolf ECU dialed in for its setup. I know it'll run rich, but safe at least. The previous owner also said the SAFC was never tuned, so it wont run any different then how it ran previously. Still i'd like to solve the problem and be able to fine tune the engine a little more.
    thanks
    -steve
    98' 240sx SM project
    93' civic sedan wdcr scca #96 SM
    92' civic Dx gas mileage monster

  • #2
    There's a thick red wire going to the ECU. Tap that for a constant 12V source. You're not going to fry anything.
    She's built like a Steakhouse, but she handles like a Bistro.

    Comment


    • #3
      Thanks i'll give it a try.
      98' 240sx SM project
      93' civic sedan wdcr scca #96 SM
      92' civic Dx gas mileage monster

      Comment

      Working...
      X