Announcement

Collapse
No announcement yet.

Stock sr20 AFR's?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Stock sr20 AFR's?

    What should they be at WOT? I don't necessarily trust my AEM wideband, but I also sorta don't trust my walbro lol. Mods are: Stock redtop @ 7psi (backed it off from 10psi just to be safe), fmic, stock elbow, 3" dp (wideband at the end of the dp), HKS exhaust, k&n filter.

    Thanks!

    Alex
    Last edited by e1_griego; 07-21-2008, 07:53 PM.

  • #2
    Ok, more info: the car is leaning out after shifts (16-18:1) when I get back on the gas. I thought it was just the vented bov, but I removed the vac line and plugged it, and doesn't change. I pulled the walbro out to check the connections and everything--it all looked good. Not much fuel came out of the lines though, and I always remember--maybe incorrectly--that quite a bit of fuel came out of the feed line. The return line looked pretty dry.

    I'm really thinking it's the fuel pump. I tend to run the tank low, and I'm sure coilovers don't help anything. Pump has been installed for a year now.

    On boost I'm in the low 12s @ 7psi; high 12s and sometimes 13s @10-11psi. Not good, I know.

    Alex

    Comment


    • #3
      Check for boost leaks on the leaning out issue. Stock ecu will do about 14:1 in the midrange and dropping to 12:1 or so running about 8-9 psi.
      '18 Chevrolet Volt - Electric fun hatch for DD duty!


      DefSport Koni Sleeve and Spring Perch Buy!!!
      http://www.nissanroadracing.com/showthread.php?t=5902

      Comment


      • #4
        It's been a long time since I looked at a stock fuel map. Yikes. Your AFR's sound about right. The AFR's should start high as you come on to full boost and then decrease as you approach redline.

        I'm going to go a different way than Def and suggest check that the TPS is working correctly for the 16-18 AFR's. It sounds like a tip-in issue, which relates to the TPS.
        She's built like a Steakhouse, but she handles like a Bistro.

        Comment


        • #5
          I just checked for boost leaks and found a couple tiny ones, so that's sorted. I also just went ahead and replaced the fuel filter for good measure.

          I checked the tps voltage a couple of days ago, and it seems fine --- .47 closed and 4.1X wide open. Opening and closing it shows a smooth/linear voltage increase.

          Of course now the tank seal is leaking too lol. Always something...


          Alex

          Comment


          • #6
            Freshalloy is back and I just found your post def:



            That basically seems like my car. So, I guess it's not really abnormal.

            Alex

            Comment


            • #7
              Is that a graph that Def made? Is that graph with a stock fuel pump?
              She's built like a Steakhouse, but she handles like a Bistro.

              Comment


              • #8
                Yeah I think so.

                http://forums2.freshalloy.com/showth...light=sr20+afr

                Alex

                Comment

                Working...
                X